Ashley sands avatar image
Ashley sands asked

Unmapped platform error

Hi, Im currently in the process of implementing the PlayFab Party SDK for windows using the nuget package (version 1.7.20) of which I'm receiving an Unmapped platform error when creating an new network.

I start by initializing the PartyManager with my title ID followed by creating a local user with the EntityId and EntityToken obtained via Login With Custom ID

I then define the PartyNetworkConfiguration as follows

 netConfig.maxUserCount = 2;
     netConfig.maxDeviceCount = 2;
     netConfig.maxDevicesPerUserCount = 1;
     netConfig.maxEndpointsPerDeviceCount = 1;
     netConfig.maxUsersPerDeviceCount = 1;
     netConfig.directPeerConnectivityOptions = PartyDirectPeerConnectivityOptions::AnyPlatformType | PartyDirectPeerConnectivityOptions::AnyEntityLoginProvider;

and the initial invitation as

 PartyInvitationConfiguration invertation = PartyInvitationConfiguration();
 invertation.identifier = uuid;
 invertation.revocability = PartyInvitationRevocability::Anyone;
 invertation.entityIds = nullptr;
 invertation.entityIdCount = 0;

then i call CreateNewNetwork( localUser, &netConfig, 0, nullptr, &invertation, nullptr, out_descriptor, nullptr );

The initial request goes through without any issue. However when i receive the Create New Network Completed State Change i get a result of 1 (Unknow error) with error detail 8 (unmapped platform error)

For the sake of testing iv inputted a faked Entity Token to see if it will give a different error of witch i get "malformed Entity token" which I guess is expected.

Furthermore, iv crossed reference my implementation with a different project I'm working on using the Unity Party SDK and iv gone over the PartySamples in the git repo too. Iv tried defining PARTY_WINDOWS, PLATFAB_PLATFORM_WINDOWS among others. All to no avail.

I cant find any documentation regarding the error nor any way to define the platform.

Please help and thanks in advance.

10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

Simon Cui avatar image
Simon Cui answered

You may try using the latest version of Party SDK to see if the issue persists. Please let us know if you have any further question of this issue.

10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Ashley sands avatar image Ashley sands commented ·

Hi, thanks for a response. Iv updated to the latest version (1.7.22) of which I still get the Unmapped platform error

0 Likes 0 ·
Simon Cui avatar image Simon Cui Ashley sands commented ·

Thanks for the information. You can refer to PartyNetworkConfiguration and PartyDirectPeerConnectivityOptions. We will do more research on this issue as well.

0 Likes 0 ·
Ashley sands avatar image Ashley sands Simon Cui commented ·

Currently i have the PartyNetworkConfiguration.DirectPeerConnectivityOptions set to AnyPlatformType, AnyEntityLoginProvider As we are looking to do cross platform comm's while currently we are using Login With Custom ID however we will be changing that to log in with PlayFab in the future.

Since my original post, iv added Device->CreateChatControl(/*params...*/) and configured it to system defaults to see if that makes any difference, of which nothing changed apart from the mic icon popping up in system tray (on taskbar). So it does appear that the library initialized and working to some degree.

Thanks for continue to look into this!

0 Likes 0 ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.