question

David James avatar image
David James asked

GSDK unity unhealthy after upgrading

Hi, I have a project using the unity editor extension sdk: 2.116.211012, upgraded now using the latest version 2.144.220804

The project is also now using unity 2021.3.5f1

For some reason my server build (though using identical scripts, from the previous version) always return unhealthy.


Running locally (without the local container agent) goes as far as to logging the error about container can't be found.. before that though it confirms authentication of the server so it's not crashing.

Local tests aside, uploading for deployment itself as I said always returns unhealthy now..

Any ideas, greatly appreciated!

TitleID: 80718

sdksmultiplayerphoton
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

·
Dimitris Gkanatsios avatar image
Dimitris Gkanatsios answered

You should enable verbose logging on the Unity side to understand why it's crashing locally. You are using LocalMultiplayerAgent, right? PlayFab/MpsAgent: Azure PlayFab Multiplayer Servers LocalMultiplayerAgent project and helper libraries (github.com)

4 comments
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

David James avatar image David James commented ·

I am using LocalMultiplayerAgent, yes. I get initializing, active, then it goes back to initializing and eventually terminated.. Is there something I can provide you to better understand what is going on? @Dimitris Gkanatsiosaaa

Edit; I've seen Active shot out in the console, looking at the output log itself it's just Initializing, then finally terminating; with CurrentGameHealth always marked Healthy.



Edit2; At the top of the stack:

0 PlayFabMultiplayerAgentView awake
NullReferenceException: Object reference not set to an instance of an object
at AgentListener.Start () [0x0005f] in <f0b094a594f64a7f9e2d77d12db25985>:0

And then from there:

CurrentError: HTTP/1.1 400 Bad Request - 63fd2e6d-0866-470c-99e3-cbf6dd2e6ae2
Retrying heartbeat in 30s

What could this mean?

0 Likes 0 ·
David James avatar image David James commented ·

I've narrowed it down thanks to @Dimitris Gkanatsios's advice, I'm not sure what to do at this point as this is pointing to playfab sdk code, not my own.

NullReferenceException: Object reference not set to an instance of an object
Server/Assets/Code/Server/AgentListener.cs:19
LN 19: PlayFabMultiplayerAgentAPI.Start();


Definitely the answer, just not the solution.

0 Likes 0 ·
Dimitris Gkanatsios avatar image Dimitris Gkanatsios commented ·

sorry, not sure what's going on. Is the "PlayFabMultiplayerAgentAPI" null? The "Start" method is static, so not sure what's null.

gsdk/PlayFabMultiplayerAgentAPI.cs at main PlayFab/gsdk (github.com)

0 Likes 0 ·
David James avatar image David James Dimitris Gkanatsios commented ·

It was a number of things I found wrong with my old code after upgrading unity/editor sdk, one of which:

https://community.playfab.com/questions/63863/server-version-of-isclientloggedin.html


And the other being non-playfab related but eventually I sorted it out and the server managed to reach deployment.

Thanks for taking the time.

1 Like 1 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.