question

Nick He avatar image
Nick He asked

PlayFab Bug: PlayFabClientAPI.GetPhotonAuthenticationToken no response on WebGL

I've implemented the following for the Photon-Playfab merging. It works in the editor, but in the WebGL build, the callbacks (both) for the method are never executed, and the game gets stuck after. Could it be a potential bug? Thanks a lot for your time!

PlayFabClientAPI.GetPhotonAuthenticationToken(new GetPhotonAuthenticationTokenRequest()

{

PhotonApplicationId = "SOME-HARD-CODED-ID"

}, AuthenticateWithPhoton, DisplayPlayFabError);

photon
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Xiao Zha avatar image Xiao Zha commented ·

I will do some research.

1 Like 1 ·
Xiao Zha avatar image
Xiao Zha answered

We can’t reproduce your issue. In our Test project the method works fine. Please make sure the PlayFabClientAPI.GetPhotonAuthenticationToken method has been executed. If not, the callbacks certainly do not execute. You can add some debug statements to confirm whether the method is executed.


webgl-screenshot1.png (501.5 KiB)
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Nick He avatar image
Nick He answered

Any thoughts on this? Thanks a lot for your time!

10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Error rendering WebPanel (widgets/consolidation-widget.ftl): org.hibernate.hql.internal.ast.QuerySyntaxException: AvailableConsolidation is not mapped [from AvailableConsolidation up where up.node = :node]