Mackenzie Power avatar image
Mackenzie Power asked

SMTP Server Response 5.7.57 SMTP; Client was not authenticated to send anonymous mail during


We're trying to get the SMTP Add-on working but are having troubles. We're setting it up to do email verification and have set all the settings on PlayFabs end correctly (to the best of our knowledge). We are able to trigger the email event but the "sent_email" JSON log shows an error:

"ErrorName": "SmtpServerAuthenticationError",

  "ErrorMessage": "The SMTP server requires a secure connection or the client was not authenticated. The server response was: 5.7.57 SMTP; Client was not authenticated to send anonymous mail during MAIL FROM

We are currently using port 25, when we used port 587 we kept getting a a timeout error:

"ErrorMessage": "SMTP client timed out sending mail to",

  "ErrorName": "EmailClientTimeout",

We've tried using a different outlook email to confirm the issue was not email specific (our emails do have a custom domain but they are through outlook if that is a factor), multi factor authentication is not enabled, and toggled SMTP AUTH on our accounts. We've basically followed the guild provided her to the letter:

Any help you can provide would be greatly appriciated.


Account ManagementAuthentication
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Seth Du avatar image Seth Du ♦ commented ·

The errors in events indicate that SMTP server is not working, it means the configuration is not correct. There should be issues on your Office 365 settings.

I have noticed that there are few limitations on using Office 365 as SMTP server. Would you mind check the official documentation on: How to set up a multifunction device or application to send email using Microsoft 365 or Office 365?

I am not an expert on Office 365, if necessary, would you also consult the Office 365 technical support?

0 Likes 0 ·
Mackenzie Power avatar image Mackenzie Power Seth Du ♦ commented ·

We've gone through the link you provided and tried making the necessary changes but had no luck.
I've done more digging and can confirm that the issue is on the Office365 side.
We were able to get an SMTP server running and sending out the emails correctly using the following process:
1.) Log into your Gmail

2.) Set up 2-factor verification by going to "Security" and enabling "2 Step Verification"

3.) Navigate to the app passwords section:

4.) select "Other (Custom name)" and give it a name (the name you give it is not important, as long as it helps you know what it is being used for).

5.) Select "Generate" and a new app password will be displayed for you.

6.) Copy the new password and then go into the SMTP Add-On for PlayFab

7.) Fill out the fields like you normally would but use the app password as you password:

Host name: Port number: 587 Username: Password: "The App password you copied from Google"

SMTP should work.

I suspect we'll need to do the same for Office365 in order for it to work, but I can't confirm that until I work with our systems admin to further troubleshoot and try that out.

0 Likes 0 ·
Seth Du avatar image Seth Du ♦ Mackenzie Power commented ·

My testing Title is also using Gmail, and it works fine. I have set an App password and use port 587.

I think you may try to contact Office 365 support team to get dedicated assistance on this issue.

If you have any updates, please feel free to let us know.

1 Like 1 ·

0 Answers


Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.