question

e.timofeev@flexilestudio.com avatar image
e.timofeev@flexilestudio.com asked

Problem with integration of Android push plugin.

Hi.

I tried to use android push plugin, which is provided as part of new playfab Unity SDK V2.

(I have updated playfab plugin, and then I applied AndroidPushPlugin for Unity 5.x)

I configured my app according this article - https://api.playfab.com/docs/push-for-android, and during testing I faced with issue - seems like application silently crashes on this line (Init method from PlayFabAndroidPlugin class in PlayFabAndroid):

AndroidPlugin = new AndroidJavaClass("com.playfab.unityplugin.PlayFabUnityAndroidPlugin");

So, as I said before - I configured my app in google services and in playfab itself, I receive success callback from LoginWithAndroidDeviceID method, and then it falls in PlayFabAndroidPlugin.Init method.

When I checked logs from device, I found these lines, which are definitely cause this issue:

I/Unity ( 8535): java.lang.ClassNotFoundException: com.playfab.unityplugin.PlayFabUnityAndroidPlugin

I/Unity ( 8535): Caused by: java.lang.ClassNotFoundException: Didn't find class "com.playfab.unityplugin.PlayFabUnityAndroidPlugin" on path: DexPathList[dexElements=[zip file "/mnt/asec/pigbang.flex.su-1/pkg.apk"],nativeLibraryDirectories=[/mnt/asec/pigbang.flex.su-1/lib, /vendor/lib, /system/lib]]

Seems like I built my project incorrectly, or something like this, but I can't figure out, what was done wrongly.

Here is my plugin folder (may be some plugins could affect work of another one):

Also, I tried to change some lines in AndroidManifest (I saw some posts where people faced with similar problems and tried to solve them in this way):

from ".GCM.PlayFabGcmListenerService" to "com.playfab.unityplugin.GCM.PlayFabGcmListenerService"

and some other similar lines, but it doesn't help.

So, may be I forgot something obvious, or there should be done some additional steps, which wasn't mentioned before in guides. Any helpful thoughts will be appreciated.

Also, please let me know if you have updated guide for integration android push plugin (from Unity SDK V2.) or something like this.

Thanks in advance.

Push Notifications
plugins.jpg (57.5 KiB)
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

·
Zac Bragg avatar image
Zac Bragg Deactivated answered

Hello,

Can you remove the 5.x plugin, and try out the 4.7 version?

We are seeing major issues being reported on the plugin, and our team will be investigating this in the near future. At this point I do not have an ETA, but do keep me posted with what you are finding with the legacy 4.7 version.

Thanks,

Zac

10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Error rendering WebPanel (widgets/consolidation-widget.ftl): org.hibernate.hql.internal.ast.QuerySyntaxException: AvailableConsolidation is not mapped [from AvailableConsolidation up where up.node = :node]