Thomas LAURENT avatar image
Thomas LAURENT asked

Can't use Google Authentication, Social.localUser.Authenticate callback's success is false in Unity Editor and the game crashes on Android


I've followed each step of this tutorial: and if I test the Social.localUser.Authenticate function the callback get a success to false when tested in the Unity Editor (I guess it's normal since it was not made on an android device).
On an android device when I hit the sign in button (triggering the aforementioned function) the game crashes.

Because of that crash I've no way to try any debugging.

Do you have any hint?

10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

JayZuo avatar image
JayZuo answered

You are right, Google SignIn won't work within Unity Editor. You will need to test it with an Android device. Please follow this video: to set up Google Play Games Services first. Then you can refer to the sample to build your own project. At first, you can only import Google Play Games SDK without PlayFab SDK. Once you can sign in with Google, then it would be easy to add PlayFab SDK and login with Google account.

10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Thomas LAURENT avatar image Thomas LAURENT commented ·

I come from Gamesparks mBaaS, the Google Play authentication worked well and after some time and updates of the Google Play Games SDK it seems my version (v9.50) has a known bug which causes the crash (more info here :, I'm actually testing a new update to see if that fixes the crash.

If the update doesn't solve my problem I'll try the quick manual fix for my current version and if it doesn't work I'll do as you suggested. In any case I'll post here what fixed my problem ;)

If others have the same problem I'm going into more details :

I've tested with the Google Play Games SDK Minimal sample scene and that's already making the app crash, I've reviewed the logcat on my device and I got this error "**** **** APP ID IS NOT CORRECTLY CONFIGURED TO USE GOOGLE PLAY GAME SERVICES **** Application ID ( 123456789012) must be a numeric value. **** Please verify that your manifest refers to the correct project ID. ****", a space character in the project ID field of the AndroidManifest.xml cause this error (123456789012 is not the true project ID, that's a dummy one I'm using for this comment).

0 Likes 0 ·
JayZuo avatar image JayZuo ♦ Thomas LAURENT commented ·

Oh yeah, I had the same error before, you can update Google Play Games SDK to the latest version to see if it works. Or try to replace "\ " with "\u003" as the issue suggested.

1 Like 1 ·
Thomas LAURENT avatar image Thomas LAURENT JayZuo ♦ commented ·
  • I've tried GooglePlayGamesPlugin-0.10.06 (latest version), when compiling it throws a TargetInvocationException (same error as, when building Unity freezes at loading scene 0.
  • I've tried it on an empty project and the same things happens.
  • So I've rolledback to my 0.9.50 version and replaced in Assets\GooglePlayGames\Editor\template-AndroidManifest.txt "\ __APP_ID__" by "\u003__APP_ID__" then I regenerated the AndroidManifest with my new fresh template going into Window/Google Play Games/Setup/Android setup... and pressing the Setup button.
    Once the game is built I've testing on my android device and the problem vanished, yay!
0 Likes 0 ·
Show more comments

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.