Anton avatar image
Anton asked

Matchmaking stopped working for me + unity downloads wrong secret key

everything was fine for monthes untill today. My Title ID is 5626.

I started experiancing a bug - my unity-built custom server started saying NetworkError.NoResources when I send data through NetworkTransport.Send(). In local tests the same build works ok, so this is something related to cloud.

While examining whats wrong I upgraded playfab sdk to recent version. Now I have 2 problems:

- FIRST PROBLEM: playfab editor extensions always has wrong developer secret key.

so in secret keys tab and in editor extensions its always different keys. Seems that the one in unity is incorrect. I've checked that PlayFabEditorApi.GetStudios returns wrong key, its not caching outdated key problem.

Nevertheless, I've managed to workaround this problem just by avoiding to open playfab sdk and inserting correct secret key in settings scriptable object.

- SECOND PROBLEM: matchmaking fails now.

Here is screenshot of my code (working fine before updating playfab)

here is my matchmakingrequest
{PlayFab.ClientModels.MatchmakeRequest} base: {PlayFab.ClientModels.MatchmakeRequest} BuildVersion: "0.2.8" CharacterId: null GameMode: "TestMode" LobbyId: null Region: "EUWest" StartNewIfNoneFound: false StatisticName: null TagFilter: null

and this is the error returned
error "/Client/Matchmake PlayFabError(ServiceUnavailable, Generic/unknown HTTP error, 400 BadRequest)" ApiEndpoint: "/Client/Matchmake" CustomData: null Error: ServiceUnavailable ErrorDetails: null ErrorMessage: "Generic/unknown HTTP error" HttpCode: 400 HttpStatus: "BadRequest"

Also I tried clean reinstall of playfab unity sdk with no luck. Uploaded builds multiple times, tried different regions, certainly waited untill server instance status turns to 'running', triple checked my game version, region and game mode settings.
1 comment
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Anton avatar image Anton commented ·

so I've solved second problem (with matchmaking) by downgrading playfabSDK to my old version (from SDK 2.49.180829 down to SDK 2.42.180618). My unity version is currently 2018.2.2.

tried upgrading SDK again (through playfab editor extensions) and received following error:

So now I think its actually upgrade problem.

As for NetworkError.NoResources problem it was because unity custom server that runs in headless mode has also headless framerate - Update() was called roughly 10000 a second, and sending something over network with such frequencies understandably gave NoResources error. But how could it work earlier, remains a mystery. Hope this helps somebody else:)

So, to summarize, I have 2 problems left

- how to upgrade to new sdk version in unity without mentioned error?

- how could it be that secret keys are different on the site and in actual game?

However, none of those problems are blocking development process now.

0 Likes 0 ·

1 Answer

Andy avatar image
Andy answered

For your first issue (upgrading plugin) I'm not sure exactly what might be going wrong. I've never run into issues upgrading through the editor extensions. You might want to try completely removing the extensions, reinstalling them, and then downloading the SDK fresh. Alternatively, people periodically run into issues install and SDK when their project isn't currently able to compile successfully. Ensure you're in a compiling state when upgrading.

For the second (different secret key), please be aware that the developer secret key used by the unity editor extensions are not the same as the secret keys displayed in Game Manager. When you log into PlayFab using your developer account, we actually generate a temporary key that is used for the lifetime of that session in the editor. It's expected that a) it changes from time to time and b) it's not the same as the secret keys you see in Game Manager.

10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.