question

shawnryanbruno avatar image
shawnryanbruno asked

GSDK - Unreal Engine 5.3

Is there a workaround to getting the GSDK to work in UE 5.3 yet? I can't exactly downgrade my project to a lower version and I desperately need the GSDK to work.

As it stands right now, the GSDK only works up to UE 5.2.1.

If no fix yet, when can we expect this update? Thanks,

unreal
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

1 Answer

·
Xiao Zha avatar image
Xiao Zha answered

Sorry for the inconvenience. Currently, PlayFab does not have an ETA for UE 5.3 GSDK. You may keep an eye on gsdk/UnrealPlugin at main · PlayFab/gsdk · GitHub for the latest updates.

2 comments
10 |1200

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.

Robyn To avatar image Robyn To commented ·

Is there an update on this?

0 Likes 0 ·
Xiao Zha avatar image Xiao Zha Robyn To commented ·

Sorry for the confusion. PlayFab does not provide specific version of GSDK for the specific version of Unreal Engine. And as the you can see in https://learn.microsoft.com/en-us/gaming/playfab/features/multiplayer/servers/server-sdks/unreal-gsdk/ , the PlayFab Unreal GSDK plugin will be actively maintained to work with the latest 3 - 4 versions of Unreal. If something fails using these versions, you could open an issue here: https://github.com/PlayFab/gsdk/issues . So, you could try the latest GSDK and if you get any issues, you could report the issue in PlayFab Unreal GSDK Repo.

0 Likes 0 ·

Write an Answer

Hint: Notify or tag a user in this post by typing @username.

Up to 2 attachments (including images) can be used with a maximum of 512.0 KiB each and 1.0 MiB total.